summaryrefslogtreecommitdiff
path: root/dev-ruby/temple/temple-0.6.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/temple/temple-0.6.10.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/temple/temple-0.6.10.ebuild')
-rw-r--r--dev-ruby/temple/temple-0.6.10.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/temple/temple-0.6.10.ebuild b/dev-ruby/temple/temple-0.6.10.ebuild
new file mode 100644
index 000000000000..5c41c9156c64
--- /dev/null
+++ b/dev-ruby/temple/temple-0.6.10.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES EXPRESSIONS.md README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="An abstraction and a framework for compiling templates to pure Ruby"
+HOMEPAGE="https://github.com/judofyr/temple"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/bacon dev-ruby/tilt )"
+
+all_ruby_prepare() {
+ # Avoid test failing based on specific load ordering
+ sed -i -e '/should have use_html_safe option/,/^ end/ s:^:#:' \
+ test/filters/test_escapable.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test -S bacon --automatic --quiet || die
+}