summaryrefslogtreecommitdiff
path: root/dev-ruby/syslogger/syslogger-1.6.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/syslogger/syslogger-1.6.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/syslogger/syslogger-1.6.4.ebuild')
-rw-r--r--dev-ruby/syslogger/syslogger-1.6.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/syslogger/syslogger-1.6.4.ebuild b/dev-ruby/syslogger/syslogger-1.6.4.ebuild
new file mode 100644
index 000000000000..86f694bcc813
--- /dev/null
+++ b/dev-ruby/syslogger/syslogger-1.6.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+# if ever needed
+#GITHUB_USER="crohr"
+#GITHUB_PROJECT="${PN}"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Drop-in replacement for the standard Logger, that logs to the syslog"
+HOMEPAGE="https://github.com/crohr/syslogger"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? ( >=dev-ruby/rdoc-2.4.2 )"
+
+all_ruby_prepare() {
+ sed -i '/[Bb]undler/d' Rakefile || die
+}