summaryrefslogtreecommitdiff
path: root/dev-ruby/stringex/stringex-2.8.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-18 20:36:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-18 20:36:58 +0100
commite26a7b5ef1fe42a66a3c91fe878da93c7cf83737 (patch)
tree69f8a3ce38afa952085fc96f7f7baaa8ad9fd0c8 /dev-ruby/stringex/stringex-2.8.5-r2.ebuild
parent3a1b8b124a5b405562b6e0ccf04e7bd2ddc131a4 (diff)
gentoo auto-resync : 18:07:2022 - 20:36:57
Diffstat (limited to 'dev-ruby/stringex/stringex-2.8.5-r2.ebuild')
-rw-r--r--dev-ruby/stringex/stringex-2.8.5-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/stringex/stringex-2.8.5-r2.ebuild b/dev-ruby/stringex/stringex-2.8.5-r2.ebuild
new file mode 100644
index 000000000000..16b70bb6361d
--- /dev/null
+++ b/dev-ruby/stringex/stringex-2.8.5-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Extensions for Ruby's String class"
+HOMEPAGE="https://github.com/rsl/stringex"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/i18n:1
+ dev-ruby/redcloth
+ dev-ruby/test-unit:2
+ )"
+
+all_ruby_prepare() {
+ # Let tests work with newer rails versions
+ sed -i -e 's/update_attributes/update/' test/unit/acts_as_url/adapter/* || die
+}
+
+each_ruby_prepare() {
+ if has_version "dev-ruby/activerecord[ruby_targets_${_ruby_implementation},sqlite]" ; then
+ einfo "Testing activerecord integration"
+ else
+ rm -f test/unit/acts_as_url_integration_test.rb || die
+ fi
+}