summaryrefslogtreecommitdiff
path: root/dev-ruby/state_machine/state_machine-1.2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-ruby/state_machine/state_machine-1.2.0-r1.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-ruby/state_machine/state_machine-1.2.0-r1.ebuild')
-rw-r--r--dev-ruby/state_machine/state_machine-1.2.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/state_machine/state_machine-1.2.0-r1.ebuild b/dev-ruby/state_machine/state_machine-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..f45c78ab4e74
--- /dev/null
+++ b/dev-ruby/state_machine/state_machine-1.2.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Adds support for creating state machines for attributes on any Ruby class"
+HOMEPAGE="http://www.pluginaweek.org"
+IUSE="test"
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/{unit,functional}/*_test.rb
+}