summaryrefslogtreecommitdiff
path: root/dev-ruby/sshkit/sshkit-1.19.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /dev-ruby/sshkit/sshkit-1.19.1.ebuild
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'dev-ruby/sshkit/sshkit-1.19.1.ebuild')
-rw-r--r--dev-ruby/sshkit/sshkit-1.19.1.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-ruby/sshkit/sshkit-1.19.1.ebuild b/dev-ruby/sshkit/sshkit-1.19.1.ebuild
deleted file mode 100644
index 2e3a0b61bd06..000000000000
--- a/dev-ruby/sshkit/sshkit-1.19.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby24 ruby25 ruby26"
-
-# There are functional tests that require vagrant boxes to be set up.
-RUBY_FAKEGEM_TASK_TEST="test:units"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="SSHKit makes it easy to write structured, testable SSH commands in Ruby"
-HOMEPAGE="https://github.com/capistrano/sshkit"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/net-ssh-2.8.0:*
- >=dev-ruby/net-scp-1.1.2
-"
-
-ruby_add_bdepend "test? ( dev-ruby/minitest dev-ruby/mocha )"
-
-all_ruby_prepare() {
- sed -i -e '/bundler/I s:^:#:' Rakefile test/helper.rb || die
- sed -i -e '/\(turn\|unindent\|reporters\)/I s:^:#:' \
- -e '1irequire "set"; require "pathname"' test/helper.rb || die
-
- # Fix assumption about parent directory name
- sed -i -e '/assert_match/ s/sshkit/sshkit.*/' test/unit/test_deprecation_logger.rb || die
-}
-
-each_ruby_test() {
- # Run tests directly to avoid dependencies in the Rakefile
- ${RUBY} -Ilib:test:. -e "Dir['test/unit/**/test*.rb'].each{|f| require f}" || die
-}