summaryrefslogtreecommitdiff
path: root/dev-ruby/spring/spring-2.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/spring/spring-2.0.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/spring/spring-2.0.2.ebuild')
-rw-r--r--dev-ruby/spring/spring-2.0.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/spring/spring-2.0.2.ebuild b/dev-ruby/spring/spring-2.0.2.ebuild
new file mode 100644
index 000000000000..9f7edf42288a
--- /dev/null
+++ b/dev-ruby/spring/spring-2.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_TASK_TEST="test:unit"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Rails application preloader"
+HOMEPAGE="https://github.com/rails/spring"
+SRC_URI="https://github.com/rails/spring/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1.1"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activesupport-4.2:*"
+
+ruby_add_bdepend "test? ( dev-ruby/bundler dev-ruby/activesupport )"
+
+all_ruby_prepare() {
+ sed -i -e '/files/d' \
+ -e '/bump/d' ${PN}.gemspec || die
+ sed -i -e '/bump/d' Rakefile || die
+}