summaryrefslogtreecommitdiff
path: root/dev-ruby/slim/slim-4.1.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-29 15:53:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-29 15:53:38 +0100
commit822a054dd1bab7f8080ccd486398034b4ff0b97d (patch)
treec64bfd54aca68af69ccf06b1a9d20365383e3ccc /dev-ruby/slim/slim-4.1.0-r2.ebuild
parentf7436a5ce1c11f1c33cd09dd757f768cd07b19fd (diff)
gentoo auto-resync : 29:03:2023 - 15:53:38
Diffstat (limited to 'dev-ruby/slim/slim-4.1.0-r2.ebuild')
-rw-r--r--dev-ruby/slim/slim-4.1.0-r2.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-ruby/slim/slim-4.1.0-r2.ebuild b/dev-ruby/slim/slim-4.1.0-r2.ebuild
deleted file mode 100644
index c3fb2f8c0485..000000000000
--- a/dev-ruby/slim/slim-4.1.0-r2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_RECIPE_DOC="rake"
-RUBY_FAKEGEM_TASK_DOC="yard"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A template language aiming to reduce the syntax to the essential parts"
-HOMEPAGE="http://slim-lang.com/"
-LICENSE="MIT"
-
-KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv x86"
-SLOT="$(ver_cut 1)"
-IUSE="doc"
-
-ruby_add_rdepend ">=dev-ruby/tilt-2.0.6:* =dev-ruby/tilt-2.0*:*
- >=dev-ruby/temple-0.7.6:0.7
- !!<dev-ruby/slim-3.0.9-r1"
-
-ruby_add_bdepend "doc? ( dev-ruby/yard dev-ruby/redcarpet )"
-
-ruby_add_bdepend "test? ( dev-ruby/redcarpet dev-ruby/sassc )"
-
-all_ruby_prepare() {
- sed -i -e '/bundler/I s:^:#:' Rakefile || die
-
- # This sinatra code expects tests to be installed but we strip those.
- sed -i -e "s/require 'sinatra'/require 'bogussinatra'/" Rakefile || die
-
- # Add missing include, bug 816573
- sed -i -e "1irequire 'ostruct'" test/core/test_code_evaluation.rb || die
-
- # Avoid tests for things we don't have. The builder test does not pass with tilt 2.x
- sed -i -e '/test_wip_render_with_asciidoc/,/^ end/ s:^:#:' \
- -e '/test_render_with_wiki/,/^ end/ s:^:#:' \
- -e '/test_render_with_creole/,/^ end/ s:^:#:' \
- -e '/test_render_with_builder/,/^ end/ s:^:#:' \
- -e '/test_render_with_org/,/^ end/ s:^:#:' test/core/test_embedded_engines.rb || die
-
- sed -i -e '/s\.files/ s/git ls-files/find . -type f -print/' \
- -e '/s\.executables/ s:git ls-files -- bin/\*:find bin -type f -print:' ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-each_ruby_prepare() {
- sed -i -e '/Open3/ s:ruby:'${RUBY}':' test/core/test_commands.rb || die
-}