summaryrefslogtreecommitdiff
path: root/dev-ruby/simplecov_json_formatter/simplecov_json_formatter-0.1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-ruby/simplecov_json_formatter/simplecov_json_formatter-0.1.4.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-ruby/simplecov_json_formatter/simplecov_json_formatter-0.1.4.ebuild')
-rw-r--r--dev-ruby/simplecov_json_formatter/simplecov_json_formatter-0.1.4.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/simplecov_json_formatter/simplecov_json_formatter-0.1.4.ebuild b/dev-ruby/simplecov_json_formatter/simplecov_json_formatter-0.1.4.ebuild
new file mode 100644
index 000000000000..5201e28824d9
--- /dev/null
+++ b/dev-ruby/simplecov_json_formatter/simplecov_json_formatter-0.1.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="JSON formatter for SimpleCov"
+HOMEPAGE="https://github.com/codeclimate-community/simplecov_json_formatter"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~riscv"
+SLOT="$(ver_cut 1)"
+IUSE="doc"
+
+# Not packaged in the gem and very fragile for e.g. simplecov versions
+RESTRICT="test"