summaryrefslogtreecommitdiff
path: root/dev-ruby/simplecov
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/simplecov
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/simplecov')
-rw-r--r--dev-ruby/simplecov/Manifest5
-rw-r--r--dev-ruby/simplecov/metadata.xml11
-rw-r--r--dev-ruby/simplecov/simplecov-0.14.1.ebuild41
-rw-r--r--dev-ruby/simplecov/simplecov-0.16.1.ebuild46
4 files changed, 103 insertions, 0 deletions
diff --git a/dev-ruby/simplecov/Manifest b/dev-ruby/simplecov/Manifest
new file mode 100644
index 000000000000..386e1bbd519a
--- /dev/null
+++ b/dev-ruby/simplecov/Manifest
@@ -0,0 +1,5 @@
+DIST simplecov-0.14.1.gem 58880 BLAKE2B 61882c34341555ce47df82f8931a8c457d0c6d69a143fa4c9999ff0b3aafb8510d2957627e1dfa9e3819c1509670fdc0a062021eb6655914cc935f9abbd584a1 SHA512 7b62fef6df1d3b395b03a5444d65430ae645aca7c13e6694f4377b35a82c0b4503e5d53a94512ff06e634a6d81331a8bce31787dba793517ecd3e502220afbaf
+DIST simplecov-0.16.1.tar.gz 62296 BLAKE2B f9ebe2c7ec3d8b5bb80f642be3e9803210f9af334a2e7eacc2d1339567750027bf0505106e9fd641c42b3ad41e5e74ebbe730d8ff80947b1ec2ff23f6ee8fef1 SHA512 5b3c16bcdcbfcbd5282bd91375d1593292ad421a73b88cbdf18fc8f57364e20e1eec44bb084be3619684f9871612ca81f790eea8eec98b61cf523bf38b4a997f
+EBUILD simplecov-0.14.1.ebuild 999 BLAKE2B dfaad6b5f99b81d6f084baced7a1e663fbd355218ce2c5a73865ae8a43c227c8da1911520ce19c57f155ab5bb5a7fe11ebd5838a9212d82837b2bb9ba701e0bf SHA512 dcc3b1db6df4cec60c4fa9d1f61e57e95c19a5ae7361905577a84e50ce393b36a5616814b10bf164a228e72d8b2cf4b899fb34694b03d6f29ee33cb84205587d
+EBUILD simplecov-0.16.1.ebuild 1245 BLAKE2B 04ad3b45019ac0034fe62eea5094c59dd3f272b81890f4f972a4a5746ff52bd971d21e97ff4ea665fa9b0f74dda3963076f67c4e3a6b5b4023c742dff201c503 SHA512 d9380ab9eda9fef280ae8d4e8346316a23b94a89f5603fad89c4ff386e77bd7044a8b8f12da2af7e05fd98982c4afdcbd93da3f3f3703268a82322e2d37f4a56
+MISC metadata.xml 345 BLAKE2B b1b086ff87954b47674d7c4ea2e3179d43c10fab22383c937600b0b83675a9dba5434dc9425a1dd1bfff27c8bb81d36fc558523a0b80ed818a37ff9585dc094f SHA512 ca0ae8784caca2cc0091622a5bfa3796600239a0d81bc5338eb36f743db99f36ba7b50866b1de1cd2ae541f2c2dff96c648f5cdb0661ab766501f4c757d2ddd5
diff --git a/dev-ruby/simplecov/metadata.xml b/dev-ruby/simplecov/metadata.xml
new file mode 100644
index 000000000000..e781caffa063
--- /dev/null
+++ b/dev-ruby/simplecov/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">colszowka/simplecov</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/simplecov/simplecov-0.14.1.ebuild b/dev-ruby/simplecov/simplecov-0.14.1.ebuild
new file mode 100644
index 000000000000..f654c61a46c8
--- /dev/null
+++ b/dev-ruby/simplecov/simplecov-0.14.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Code coverage with a configuration library and merging across test suites"
+HOMEPAGE="https://www.ruby-toolbox.com/projects/simplecov https://github.com/colszowka/simplecov"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0.8"
+IUSE="doc"
+
+ruby_add_rdepend ">=dev-ruby/json-1.8:0 <dev-ruby/json-3:0
+ dev-ruby/simplecov-html:0.10
+ =dev-ruby/docile-1.1*"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec:3
+ dev-ruby/test-unit:2
+)"
+
+# There are also cucumber tests that require poltergeist and unpackaged phantomjs gem.
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' spec/helper.rb features/support/env.rb || die
+}
+
+each_ruby_test() {
+ RSPEC_VERSION=3 ruby-ng_rspec spec/*spec.rb || die
+
+ #${RUBY} -S cucumber features || die
+}
diff --git a/dev-ruby/simplecov/simplecov-0.16.1.ebuild b/dev-ruby/simplecov/simplecov-0.16.1.ebuild
new file mode 100644
index 000000000000..1f07bb975283
--- /dev/null
+++ b/dev-ruby/simplecov/simplecov-0.16.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Code coverage with a configuration library and merging across test suites"
+HOMEPAGE="https://www.ruby-toolbox.com/projects/simplecov https://github.com/colszowka/simplecov"
+SRC_URI="https://github.com/colszowka/simplecov/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0.8"
+IUSE="doc"
+
+ruby_add_rdepend "|| ( dev-ruby/json:2 >=dev-ruby/json-1.8:0 )
+ dev-ruby/simplecov-html:0.10
+ >=dev-ruby/docile-1.1:0"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec:3
+ dev-ruby/test-unit:2
+)"
+
+# There are also cucumber tests that require poltergeist and unpackaged phantomjs gem.
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' spec/helper.rb features/support/env.rb || die
+
+ # Avoid test depending on spawning ruby and having timing issues
+ sed -i -e '/blocks other processes/askip "gentoo"' spec/result_merger_spec.rb || die
+}
+
+each_ruby_test() {
+ RSPEC_VERSION=3 ruby-ng_rspec spec/*spec.rb || die
+
+ #${RUBY} -S cucumber features || die
+}