summaryrefslogtreecommitdiff
path: root/dev-ruby/simplecov/simplecov-0.22.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-24 20:03:07 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-24 20:03:07 +0000
commitec9f79e1d3358df31a704f16a76a269ccceae2b2 (patch)
tree5982c029d09bc9e396ad5ead3d99c99ed6a58322 /dev-ruby/simplecov/simplecov-0.22.0.ebuild
parent9aefa814d833d6bdd1bdbc7d0f44d5680c9beaa8 (diff)
gentoo auto-resync : 24:12:2022 - 20:03:07
Diffstat (limited to 'dev-ruby/simplecov/simplecov-0.22.0.ebuild')
-rw-r--r--dev-ruby/simplecov/simplecov-0.22.0.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-ruby/simplecov/simplecov-0.22.0.ebuild b/dev-ruby/simplecov/simplecov-0.22.0.ebuild
new file mode 100644
index 000000000000..1f2ded59ddcd
--- /dev/null
+++ b/dev-ruby/simplecov/simplecov-0.22.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+
+RUBY_FAKEGEM_GEMSPEC="simplecov.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Code coverage with a configuration library and merging across test suites"
+HOMEPAGE="https://github.com/simplecov-ruby/simplecov"
+SRC_URI="https://github.com/simplecov-ruby/simplecov/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~riscv"
+SLOT="0.8"
+IUSE="doc"
+
+ruby_add_rdepend "
+ dev-ruby/simplecov-html:0.12
+ >=dev-ruby/simplecov_json_formatter-0.1:0
+ >=dev-ruby/docile-1.1:0"
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ dev-ruby/rspec:3
+ dev-ruby/test-unit:2
+)"
+
+# There are also cucumber tests that require poltergeist and unpackaged phantomjs gem.
+
+all_ruby_prepare() {
+ # Avoid test depending on spawning ruby and having timing issues
+ sed -i -e '/blocks other processes/askip "gentoo"' spec/result_merger_spec.rb || die
+
+ sed -i -e '5i require "bundler"' spec/helper.rb || die
+
+ sed -e '/start_coverage_measurement/,/^ end/ s|with(lines: true)|with({lines: true})|' \
+ -e '/start_coverage_measurement/,/^ end/ s|with(lines: true, branches: true)|with({lines: true, branches: true})|' \
+ -i spec/simplecov_spec.rb || die
+}
+
+each_ruby_test() {
+ RSPEC_VERSION=3 ruby-ng_rspec spec/*spec.rb || die
+
+ #${RUBY} -S cucumber features || die
+}