summaryrefslogtreecommitdiff
path: root/dev-ruby/simplecov-html
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/simplecov-html
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/simplecov-html')
-rw-r--r--dev-ruby/simplecov-html/Manifest3
-rw-r--r--dev-ruby/simplecov-html/metadata.xml11
-rw-r--r--dev-ruby/simplecov-html/simplecov-html-0.10.2.ebuild23
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/simplecov-html/Manifest b/dev-ruby/simplecov-html/Manifest
new file mode 100644
index 000000000000..ed3961f47b57
--- /dev/null
+++ b/dev-ruby/simplecov-html/Manifest
@@ -0,0 +1,3 @@
+DIST simplecov-html-0.10.2.gem 183296 BLAKE2B f4edfe25249927d46f32d422b004d8a03671926792ea78016864764242f8bf8dc9131a0580b9519db6798beb3fa093f79a0d585b63d6b6b62c9faf7ae94087e8 SHA512 141b9d55ca7cbf1bb64616482828107c7c33c7d6db1b5650ae9d463e5ece7a7fb56d123c539c7364fe2a35e5faea382620a0b34e337d4c9d4871caafc794a967
+EBUILD simplecov-html-0.10.2.ebuild 528 BLAKE2B e2613e33c33b39806ea27ee26e4d10c9f26703d1677b8567451b09d5291ed4d9e6efd2756b0c9be8ef42008f9780a1fcf60dc4cd0492b539360bb8d230a12206 SHA512 b5fee3fb8b9a913aa98bc022cfd1afcf67a3d2539fbcdcae76571c74bde939d57df6f28c5d99933ede5a7702d1c4221d28ffe2e3455fb6324703db01d860a2e3
+MISC metadata.xml 345 BLAKE2B b1b086ff87954b47674d7c4ea2e3179d43c10fab22383c937600b0b83675a9dba5434dc9425a1dd1bfff27c8bb81d36fc558523a0b80ed818a37ff9585dc094f SHA512 ca0ae8784caca2cc0091622a5bfa3796600239a0d81bc5338eb36f743db99f36ba7b50866b1de1cd2ae541f2c2dff96c648f5cdb0661ab766501f4c757d2ddd5
diff --git a/dev-ruby/simplecov-html/metadata.xml b/dev-ruby/simplecov-html/metadata.xml
new file mode 100644
index 000000000000..e781caffa063
--- /dev/null
+++ b/dev-ruby/simplecov-html/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">colszowka/simplecov</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/simplecov-html/simplecov-html-0.10.2.ebuild b/dev-ruby/simplecov-html/simplecov-html-0.10.2.ebuild
new file mode 100644
index 000000000000..ef33bfe352c8
--- /dev/null
+++ b/dev-ruby/simplecov-html/simplecov-html-0.10.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRAINSTALL="assets public views"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Generates a HTML report of your SimpleCov ruby code coverage results"
+HOMEPAGE="https://github.com/colszowka/simplecov"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0.10"
+IUSE="doc"