summaryrefslogtreecommitdiff
path: root/dev-ruby/shoulda/shoulda-2.11.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/shoulda/shoulda-2.11.3-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/shoulda/shoulda-2.11.3-r2.ebuild')
-rw-r--r--dev-ruby/shoulda/shoulda-2.11.3-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/shoulda/shoulda-2.11.3-r2.ebuild b/dev-ruby/shoulda/shoulda-2.11.3-r2.ebuild
new file mode 100644
index 000000000000..97c76975b734
--- /dev/null
+++ b/dev-ruby/shoulda/shoulda-2.11.3-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+# Use rdoc recipe to avoid obsolete Rakefile
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTION_GUIDELINES.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Making tests easy on the fingers and eyes"
+HOMEPAGE="http://thoughtbot.com/projects/shoulda"
+SRC_URI="https://github.com/thoughtbot/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+RUBY_S="thoughtbot-${PN}-*"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# tests seem to be quite broken :( They require working version of
+# various rails versions. There appear to be unit and matcher tests but
+# they can't be run on their own.
+RESTRICT=test