summaryrefslogtreecommitdiff
path: root/dev-ruby/shoulda/shoulda-2.11.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/shoulda/shoulda-2.11.3-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/shoulda/shoulda-2.11.3-r2.ebuild')
-rw-r--r--dev-ruby/shoulda/shoulda-2.11.3-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/shoulda/shoulda-2.11.3-r2.ebuild b/dev-ruby/shoulda/shoulda-2.11.3-r2.ebuild
new file mode 100644
index 000000000000..fab3a0157796
--- /dev/null
+++ b/dev-ruby/shoulda/shoulda-2.11.3-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+# Use rdoc recipe to avoid obsolete Rakefile
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTION_GUIDELINES.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Making tests easy on the fingers and eyes"
+HOMEPAGE="http://thoughtbot.com/projects/shoulda"
+SRC_URI="https://github.com/thoughtbot/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+RUBY_S="thoughtbot-${PN}-*"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# tests seem to be quite broken :( They require working version of
+# various rails versions. There appear to be unit and matcher tests but
+# they can't be run on their own.
+RESTRICT=test