summaryrefslogtreecommitdiff
path: root/dev-ruby/shotgun
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/shotgun
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/shotgun')
-rw-r--r--dev-ruby/shotgun/Manifest3
-rw-r--r--dev-ruby/shotgun/metadata.xml11
-rw-r--r--dev-ruby/shotgun/shotgun-0.9.2.ebuild36
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-ruby/shotgun/Manifest b/dev-ruby/shotgun/Manifest
new file mode 100644
index 000000000000..2096e1bc32fa
--- /dev/null
+++ b/dev-ruby/shotgun/Manifest
@@ -0,0 +1,3 @@
+DIST shotgun-0.9.2.gem 16384 BLAKE2B aa87fbaf2af41a28dac3d5fadc635ff0948dc874e0a02c6b6a9a7717e955a093862b18b6a37d76d6fbb776fb2e3b62fd5be7fffc9b97eea99719748e2c66d45a SHA512 62228b0b8bdac815e2204fd89d3e106d033cfee7668ef12406120e5a21f52770ee36c6fa7b3edf3eaf09bdfde5849239364d3483a817914024c21618897e8d9a
+EBUILD shotgun-0.9.2.ebuild 825 BLAKE2B 8030dc45e87e8ebdb84a15fdc2372a7da3c97e1b3921f4a68a9e5bb3bc22c47d3ccf357530c0366f9c718bcf3c81475be0874d10889ddd70b94d0b1c3ef8a1f7 SHA512 88ed9f9a4443a9447a1a47352c55a78a481ef5ad0392d1cedf5bb9ac4b6e8585bbfd69c71810025e1c5ec54d7a00b32a94ffe2d6e0cd19ac8bb0f30349b1dbab
+MISC metadata.xml 342 BLAKE2B 85674a1f5975afa534d61eed939d8619a1debbb3e3487baf6b02ff382d732061e1bc52dffacabc057319aa1cf0b0a09bd67685066659c225c23dde5e93214fee SHA512 9c32ae892991216ff0cbbcf0f0a3d467c019900c2f34a07702140eda576e3e8b88e622fbe7d954b65db9719c7460875e28180145cad6ddd0155cc853c733d79f
diff --git a/dev-ruby/shotgun/metadata.xml b/dev-ruby/shotgun/metadata.xml
new file mode 100644
index 000000000000..49f46f8cacf5
--- /dev/null
+++ b/dev-ruby/shotgun/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rtomayko/shotgun</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/shotgun/shotgun-0.9.2.ebuild b/dev-ruby/shotgun/shotgun-0.9.2.ebuild
new file mode 100644
index 000000000000..c3733183621e
--- /dev/null
+++ b/dev-ruby/shotgun/shotgun-0.9.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24"
+
+# No documentation task
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Forking implementation of rackup"
+HOMEPAGE="https://github.com/rtomayko/shotgun"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Warning: the code does not use gem versioning to make sure to load
+# only the right rack version so we might need to patch it to work :/
+ruby_add_rdepend 'dev-ruby/rack:*'
+ruby_add_bdepend "test? ( dev-ruby/bacon )"
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_shotgun_static.rb || die
+ ${RUBY} -Ilib test/test_shotgun_loader.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/shotgun.1
+}