summaryrefslogtreecommitdiff
path: root/dev-ruby/serialport
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/serialport
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/serialport')
-rw-r--r--dev-ruby/serialport/Manifest3
-rw-r--r--dev-ruby/serialport/metadata.xml8
-rw-r--r--dev-ruby/serialport/serialport-1.3.1.ebuild48
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-ruby/serialport/Manifest b/dev-ruby/serialport/Manifest
new file mode 100644
index 000000000000..12418b1a1204
--- /dev/null
+++ b/dev-ruby/serialport/Manifest
@@ -0,0 +1,3 @@
+DIST serialport-1.3.1.gem 25088 BLAKE2B 391188ff8a78f3998c82b17668a1aebad737643739c8087c4f32ce719dbf7bbf5f29cdc0717ab16f196020a227afc4fcfc29409331b2aabf5c6bf3382ef3496b SHA512 cdce9e13065cecf6d090d716626abb399bcc2a079be7bf1fe7755a20360218550f2f31980d62d8aae1fcc62fc62d6f7549685f865e30d2a5f40a617f5f197ed9
+EBUILD serialport-1.3.1.ebuild 1055 BLAKE2B ef37893f7cdf876008569c12ad51821d201931317ca05032fd8f509f58b9a1518c342476ef7027a1e26ec06fc2da5d77fa76336df1d6ee1de2bf9be957fbe238 SHA512 b40f4f77558ebe4d5667e89eea79d8d320c4f314a70216e4b61bd5d2e57e779d2e7f2ec4d0454bd7bb2023cd73e4a020c2ee3487f8038347c5dcba2879195b3c
+MISC metadata.xml 251 BLAKE2B e8bf2b70161d425791d65052583fd8be03b19ef3bb2a2cde34605bc93224fea9d8c6a91f0f2d630a00094ef54c0871e210da0e0134f52401bc80cb6b2358c13d SHA512 17d4dbd64468a524311a24ca065537a5b21560388efd282f3fa873e6722f70db6f83e3e5615556450905c29d5df2cf0a0855f9c0b38bf23f0f8112501456d4ea
diff --git a/dev-ruby/serialport/metadata.xml b/dev-ruby/serialport/metadata.xml
new file mode 100644
index 000000000000..eb1e47f2edfb
--- /dev/null
+++ b/dev-ruby/serialport/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-ruby/serialport/serialport-1.3.1.ebuild b/dev-ruby/serialport/serialport-1.3.1.ebuild
new file mode 100644
index 000000000000..2a43ff9b1408
--- /dev/null
+++ b/dev-ruby/serialport/serialport-1.3.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="a library for serial port (rs232) access in ruby"
+HOMEPAGE="http://rubyforge.org/projects/ruby-serialport/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Fix the miniterm script so that it might actually work, we'll
+ # install it as example.
+ sed -i -e 's:\.\./serialport.so:serialport:' test/miniterm.rb || die
+}
+
+each_ruby_configure() {
+ cd ext/native || die
+ ${RUBY} extconf.rb || die
+}
+
+each_ruby_compile() {
+ pushd ext/native &>/dev/null
+ emake V=1
+ popd &>/dev/null
+
+ # Avoids the need for a specific install phase
+ cp ext/native/*$(get_modname) lib/ || die "extension copy failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # don't compress it
+ insinto /usr/share/doc/${PF}/examples
+ doins test/miniterm.rb
+}