summaryrefslogtreecommitdiff
path: root/dev-ruby/serialport/serialport-1.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-ruby/serialport/serialport-1.3.1.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/serialport/serialport-1.3.1.ebuild')
-rw-r--r--dev-ruby/serialport/serialport-1.3.1.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-ruby/serialport/serialport-1.3.1.ebuild b/dev-ruby/serialport/serialport-1.3.1.ebuild
deleted file mode 100644
index 2a43ff9b1408..000000000000
--- a/dev-ruby/serialport/serialport-1.3.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby22 ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_TASK_TEST=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="a library for serial port (rs232) access in ruby"
-HOMEPAGE="http://rubyforge.org/projects/ruby-serialport/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE=""
-
-all_ruby_prepare() {
- # Fix the miniterm script so that it might actually work, we'll
- # install it as example.
- sed -i -e 's:\.\./serialport.so:serialport:' test/miniterm.rb || die
-}
-
-each_ruby_configure() {
- cd ext/native || die
- ${RUBY} extconf.rb || die
-}
-
-each_ruby_compile() {
- pushd ext/native &>/dev/null
- emake V=1
- popd &>/dev/null
-
- # Avoids the need for a specific install phase
- cp ext/native/*$(get_modname) lib/ || die "extension copy failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- # don't compress it
- insinto /usr/share/doc/${PF}/examples
- doins test/miniterm.rb
-}