summaryrefslogtreecommitdiff
path: root/dev-ruby/sdoc/sdoc-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ruby/sdoc/sdoc-1.1.0.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ruby/sdoc/sdoc-1.1.0.ebuild')
-rw-r--r--dev-ruby/sdoc/sdoc-1.1.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/sdoc/sdoc-1.1.0.ebuild b/dev-ruby/sdoc/sdoc-1.1.0.ebuild
new file mode 100644
index 000000000000..2f69e4f81e30
--- /dev/null
+++ b/dev-ruby/sdoc/sdoc-1.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+inherit ruby-fakegem
+
+DESCRIPTION="rdoc generator html with javascript search index"
+HOMEPAGE="https://rubygems.org/gems/sdoc"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/rdoc-5.0"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/ s:^:#:' sdoc.gemspec || die
+
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
+
+ # Avoid spec that appears to be broken with newer rdoc versions.
+ sed -i -e '/should display SDoc version/askip' spec/rdoc_generator_spec.rb || die
+}