summaryrefslogtreecommitdiff
path: root/dev-ruby/sawyer/sawyer-0.8.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
commiteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (patch)
treece35c6d01b5ff5de95c3a20fef853b9a6518ad2e /dev-ruby/sawyer/sawyer-0.8.2.ebuild
parentb7ebc951da8800f711142f69d9d958bde67a112d (diff)
gentoo resync : 04.05.2019
Diffstat (limited to 'dev-ruby/sawyer/sawyer-0.8.2.ebuild')
-rw-r--r--dev-ruby/sawyer/sawyer-0.8.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/sawyer/sawyer-0.8.2.ebuild b/dev-ruby/sawyer/sawyer-0.8.2.ebuild
new file mode 100644
index 000000000000..1bc844890d0c
--- /dev/null
+++ b/dev-ruby/sawyer/sawyer-0.8.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Secret User Agent of HTTP"
+HOMEPAGE="https://github.com/lostisland/sawyer"
+SRC_URI="https://github.com/lostisland/sawyer/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ <dev-ruby/faraday-2.0
+ >=dev-ruby/addressable-2.3.5"
+
+all_ruby_prepare() {
+ # Avoid tests that require network acces
+ sed -i -e '/test_blank_response_doesnt_raise/,/^ end/ s:^:#:' test/agent_test.rb || die
+}