summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-termios/ruby-termios-1.0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/ruby-termios/ruby-termios-1.0.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/ruby-termios/ruby-termios-1.0.2-r1.ebuild')
-rw-r--r--dev-ruby/ruby-termios/ruby-termios-1.0.2-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/ruby-termios/ruby-termios-1.0.2-r1.ebuild b/dev-ruby/ruby-termios/ruby-termios-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..bdc574354d6c
--- /dev/null
+++ b/dev-ruby/ruby-termios/ruby-termios-1.0.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md termios.rd"
+
+# There are no tests in the gem, and the upstream tests only work
+# with a normal TTY, bug 340575.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A Ruby interface to termios"
+HOMEPAGE="http://arika.org/ruby/termios"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~x86 ~x86-macos"
+IUSE=""
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext V=1
+ cp ext/termios$(get_modname) lib/ || die
+}