summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-opengl/ruby-opengl-0.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/ruby-opengl/ruby-opengl-0.10.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/ruby-opengl/ruby-opengl-0.10.0.ebuild')
-rw-r--r--dev-ruby/ruby-opengl/ruby-opengl-0.10.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-ruby/ruby-opengl/ruby-opengl-0.10.0.ebuild b/dev-ruby/ruby-opengl/ruby-opengl-0.10.0.ebuild
new file mode 100644
index 000000000000..32197eb096d0
--- /dev/null
+++ b/dev-ruby/ruby-opengl/ruby-opengl-0.10.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+# Two tests fails but the README already indicates that this may not
+# work. Additionally these tests require access to video devices such as
+# /dev/nvidiactl.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_NAME="opengl"
+
+RUBY_FAKEGEM_EXTRADOC="History.md README.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="OpenGL / GLUT bindings for ruby"
+HOMEPAGE="https://github.com/larskanis/opengl"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ppc ppc64 x86"
+
+IUSE=""
+
+DEPEND+=" virtual/opengl
+ media-libs/freeglut"
+RDEPEND+=" virtual/opengl
+ media-libs/freeglut"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/opengl extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -C ext/opengl V=1
+
+ cp ext/*/*$(get_modname) lib/opengl/ || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+}