summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-opengl/ruby-opengl-0.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/ruby-opengl/ruby-opengl-0.10.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/ruby-opengl/ruby-opengl-0.10.0.ebuild')
-rw-r--r--dev-ruby/ruby-opengl/ruby-opengl-0.10.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-ruby/ruby-opengl/ruby-opengl-0.10.0.ebuild b/dev-ruby/ruby-opengl/ruby-opengl-0.10.0.ebuild
new file mode 100644
index 000000000000..59d68824f4d1
--- /dev/null
+++ b/dev-ruby/ruby-opengl/ruby-opengl-0.10.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+# Two tests fails but the README already indicates that this may not
+# work. Additionally these tests require access to video devices such as
+# /dev/nvidiactl.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_NAME="opengl"
+
+RUBY_FAKEGEM_EXTRADOC="History.md README.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="OpenGL / GLUT bindings for ruby"
+HOMEPAGE="https://github.com/larskanis/opengl"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~ppc ~ppc64 x86"
+
+IUSE=""
+
+DEPEND+=" virtual/opengl
+ media-libs/freeglut"
+RDEPEND+=" virtual/opengl
+ media-libs/freeglut"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/opengl extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -C ext/opengl V=1
+
+ cp ext/*/*$(get_modname) lib/opengl/ || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+}