summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-ole/ruby-ole-1.2.12.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-ruby/ruby-ole/ruby-ole-1.2.12.2-r1.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-ruby/ruby-ole/ruby-ole-1.2.12.2-r1.ebuild')
-rw-r--r--dev-ruby/ruby-ole/ruby-ole-1.2.12.2-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/ruby-ole/ruby-ole-1.2.12.2-r1.ebuild b/dev-ruby/ruby-ole/ruby-ole-1.2.12.2-r1.ebuild
new file mode 100644
index 000000000000..ccc0514b0eb5
--- /dev/null
+++ b/dev-ruby/ruby-ole/ruby-ole-1.2.12.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+# Avoid the complexity of the "rake" recipe and run testrb-2 manually.
+RUBY_FAKEGEM_RECIPE_TEST=none
+
+# Same thing for the docs whose rake target just calls rdoc.
+RUBY_FAKEGEM_RECIPE_DOC=rdoc
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby library for easy read/write access to OLE compound documents"
+HOMEPAGE="https://github.com/aquasync/ruby-ole"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 --pattern='test.*\.rb' test/
+}