summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-mp3info/ruby-mp3info-0.8.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/ruby-mp3info/ruby-mp3info-0.8.9.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/ruby-mp3info/ruby-mp3info-0.8.9.ebuild')
-rw-r--r--dev-ruby/ruby-mp3info/ruby-mp3info-0.8.9.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/ruby-mp3info/ruby-mp3info-0.8.9.ebuild b/dev-ruby/ruby-mp3info/ruby-mp3info-0.8.9.ebuild
new file mode 100644
index 000000000000..b1c9c6fe8679
--- /dev/null
+++ b/dev-ruby/ruby-mp3info/ruby-mp3info-0.8.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure Ruby library for access to mp3 files (internal infos and tags)"
+HOMEPAGE="http://rubyforge.org/projects/ruby-mp3info/"
+SRC_URI="https://github.com/moumar/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND+=" test? ( media-sound/id3v2 )"
+
+ruby_add_bdepend "doc? ( dev-ruby/hoe )"
+ruby_add_bdepend "test? ( dev-ruby/hoe dev-ruby/test-unit:2 )"