summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-goffice/ruby-goffice-3.4.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ruby/ruby-goffice/ruby-goffice-3.4.3.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ruby/ruby-goffice/ruby-goffice-3.4.3.ebuild')
-rw-r--r--dev-ruby/ruby-goffice/ruby-goffice-3.4.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/ruby-goffice/ruby-goffice-3.4.3.ebuild b/dev-ruby/ruby-goffice/ruby-goffice-3.4.3.ebuild
new file mode 100644
index 000000000000..8913d2c04d0d
--- /dev/null
+++ b/dev-ruby/ruby-goffice/ruby-goffice-3.4.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_GNOME2_NEED_VIRTX=yes
+
+inherit ruby-ng-gnome2
+
+DESCRIPTION="Ruby GOffice bindings"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND+=" x11-libs/goffice[introspection]"
+RDEPEND+=" x11-libs/goffice[introspection]"
+
+ruby_add_rdepend "
+ ~dev-ruby/ruby-gsf-${PV}
+ ~dev-ruby/ruby-gtk3-${PV}"
+
+all_ruby_prepare() {
+ ruby-ng-gnome2_all_ruby_prepare
+
+ # https://github.com/ruby-gnome/ruby-gnome/issues/1316
+ sed -i -e '/only_goffice_version/s/0, 10, 27/0, 10/' \
+ test/test-data-scalar-str.rb
+}