summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-gettext/ruby-gettext-3.2.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /dev-ruby/ruby-gettext/ruby-gettext-3.2.6.ebuild
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'dev-ruby/ruby-gettext/ruby-gettext-3.2.6.ebuild')
-rw-r--r--dev-ruby/ruby-gettext/ruby-gettext-3.2.6.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/dev-ruby/ruby-gettext/ruby-gettext-3.2.6.ebuild b/dev-ruby/ruby-gettext/ruby-gettext-3.2.6.ebuild
deleted file mode 100644
index 50931eb376e1..000000000000
--- a/dev-ruby/ruby-gettext/ruby-gettext-3.2.6.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_NAME="${PN/ruby-/}"
-RUBY_FAKEGEM_VERSION="${PV%_*}"
-
-RUBY_FAKEGEM_RECIPE_DOC="yard"
-RUBY_FAKEGEM_EXTRADOC="README.md doc/text/news.md"
-
-RUBY_FAKEGEM_TASK_TEST="none"
-
-RUBY_FAKEGEM_EXTRAINSTALL="locale po"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Native Language Support Library and Tools modeled after GNU gettext package"
-HOMEPAGE="https://ruby-gettext.github.io/"
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
-IUSE="doc test"
-SLOT="0"
-LICENSE="|| ( Ruby LGPL-3+ )"
-
-ruby_add_rdepend ">=dev-ruby/locale-2.0.5 >=dev-ruby/text-1.3.0"
-
-ruby_add_bdepend "doc? ( dev-ruby/yard )
- dev-ruby/racc"
-ruby_add_bdepend "test? (
- dev-ruby/test-unit:2
- dev-ruby/test-unit-rr )"
-
-RDEPEND+=" sys-devel/gettext"
-DEPEND+=" sys-devel/gettext"
-
-all_ruby_prepare() {
- # Fix broken racc invocation
- sed -i -e '/command_line/ s/#{racc}/-S racc/' Rakefile || die
-
- # Avoid bundler dependency
- sed -i -e '/bundler/,/helper.install/ s:^:#:' \
- -e 's/helper.gemspec/Gem::Specification.new/' Rakefile || die
-
- # Avoid dependency on developer-specific tools.
- sed -i -e '/notify/ s:^:#:' test/run-test.rb || die
-
- # Avoid tests failing due to a missing test file.
- #sed -i -e '/test_invalid_charset/,/end/ s:^:#:' test/test_mo.rb || die
-}
-
-each_ruby_test() {
- # Upstream tries to daisy-chain rake calls but they fail badly
- # with our setup, so run it manually.
- ${RUBY} test/run-test.rb || die "tests failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- insinto /usr/share/doc/${PF}
- doins -r samples
-}