summaryrefslogtreecommitdiff
path: root/dev-ruby/rss
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /dev-ruby/rss
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'dev-ruby/rss')
-rw-r--r--dev-ruby/rss/Manifest3
-rw-r--r--dev-ruby/rss/metadata.xml11
-rw-r--r--dev-ruby/rss/rss-0.2.9.ebuild25
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/rss/Manifest b/dev-ruby/rss/Manifest
new file mode 100644
index 000000000000..efb63719752c
--- /dev/null
+++ b/dev-ruby/rss/Manifest
@@ -0,0 +1,3 @@
+DIST rss-0.2.9.gem 106496 BLAKE2B 4b8b4b8fc59f05b7ed513294a809b0961dcd0c8b94cbfff3cbb09102a9ad056063c4b2a5d00b30e2eebc76701b10c3b28125ba2daf49fb420c5ff37a47dd600b SHA512 24d983ae2ee8570c3e433675f9cdacd1c35d6160beb28689a0f8cf446b6b465147bef68dab644a85cb089870d6a9fb2df85cbaed12ed4d6a6fb2d07b12c6ca3f
+EBUILD rss-0.2.9.ebuild 737 BLAKE2B e72da867abdd1b2c709c7e3ce813fe4cc7103f1e1f5f687baa421f907d426d3f8ec980f6418393067e697e73684b0accd908093c4c76d70946e0c35e477a3923 SHA512 66732e2761814ede59e8ee68bb4b199787634b6856a37d4d8312b93bd62232d74b352109b0e7dde17cc1cf565d38c927d3bfadf3c7264a65c1cd27915b3a8ffb
+MISC metadata.xml 334 BLAKE2B faa6cfa109984ab609194cb0a789b45ab89968c3b4e96d32b9bb4210df06780b9bb17d79e9a996de2189e747642b9ffac6858280a38c2fe26e683cec6a008686 SHA512 b857ee7cfa2668de8f7ab897213a8f569aff396668644313b565f43d684fe93c6281486b1c2ff99026744aec4031a378f39d706d22d0f80560bacf8d1b83719c
diff --git a/dev-ruby/rss/metadata.xml b/dev-ruby/rss/metadata.xml
new file mode 100644
index 000000000000..843596d73476
--- /dev/null
+++ b/dev-ruby/rss/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby/rss</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rss/rss-0.2.9.ebuild b/dev-ruby/rss/rss-0.2.9.ebuild
new file mode 100644
index 000000000000..76de49246db3
--- /dev/null
+++ b/dev-ruby/rss/rss-0.2.9.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Family of libraries that support various formats of XML feeds."
+HOMEPAGE="https://github.com/ruby/rss"
+
+LICENSE="BSD-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE="test"
+
+ruby_add_rdepend "dev-ruby/rexml"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/,/^helper.install/ s:^:#:' Rakefile || die
+}