summaryrefslogtreecommitdiff
path: root/dev-ruby/rspec/rspec-3.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-21 21:00:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-21 21:00:58 +0100
commit8b2628ad8526c806375e7b157889e4274b70248b (patch)
treeccba8cd56af7e086131454d6062d5d31115791df /dev-ruby/rspec/rspec-3.7.0.ebuild
parentb620fb1b0929ff9657a2588aaa42b85e3021c102 (diff)
gentoo resync : 21.10.2017
Diffstat (limited to 'dev-ruby/rspec/rspec-3.7.0.ebuild')
-rw-r--r--dev-ruby/rspec/rspec-3.7.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/rspec/rspec-3.7.0.ebuild b/dev-ruby/rspec/rspec-3.7.0.ebuild
new file mode 100644
index 000000000000..326748495ebc
--- /dev/null
+++ b/dev-ruby/rspec/rspec-3.7.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+SUBVERSION="$(get_version_component_range 1-2)"
+
+ruby_add_rdepend "
+ =dev-ruby/rspec-core-${SUBVERSION}*
+ =dev-ruby/rspec-expectations-${SUBVERSION}*
+ =dev-ruby/rspec-mocks-${SUBVERSION}*"