summaryrefslogtreecommitdiff
path: root/dev-ruby/rspec-retry/rspec-retry-0.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-ruby/rspec-retry/rspec-retry-0.6.2.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-ruby/rspec-retry/rspec-retry-0.6.2.ebuild')
-rw-r--r--dev-ruby/rspec-retry/rspec-retry-0.6.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/rspec-retry/rspec-retry-0.6.2.ebuild b/dev-ruby/rspec-retry/rspec-retry-0.6.2.ebuild
new file mode 100644
index 000000000000..b39e9d270a51
--- /dev/null
+++ b/dev-ruby/rspec-retry/rspec-retry-0.6.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Retry intermittently failing rspec examples"
+HOMEPAGE="https://github.com/NoRedInk/rspec-retry"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+ruby_add_rdepend ">=dev-ruby/rspec-core-3.3:3"
+
+all_ruby_prepare() {
+ sed -i -e '/pry/ s:^:#:' spec/spec_helper.rb || die
+}