summaryrefslogtreecommitdiff
path: root/dev-ruby/rspec-core/rspec-core-3.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /dev-ruby/rspec-core/rspec-core-3.6.0.ebuild
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'dev-ruby/rspec-core/rspec-core-3.6.0.ebuild')
-rw-r--r--dev-ruby/rspec-core/rspec-core-3.6.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-ruby/rspec-core/rspec-core-3.6.0.ebuild b/dev-ruby/rspec-core/rspec-core-3.6.0.ebuild
index 6c4ff090e3f7..f003ed1ca4d2 100644
--- a/dev-ruby/rspec-core/rspec-core-3.6.0.ebuild
+++ b/dev-ruby/rspec-core/rspec-core-3.6.0.ebuild
@@ -22,7 +22,7 @@ SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
LICENSE="MIT"
SLOT="3"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~ppc ~ppc64 sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ~ia64 ~ppc ppc64 sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="highlight"
SUBVERSION="$(get_version_component_range 1-2)"
@@ -71,6 +71,10 @@ all_ruby_prepare() {
sed -i -e '/be_highlighted/,/end/ s/32/33/' \
-e '/highlights core RSpec keyword-like methods/,/^ end/ s:^:#:' \
spec/rspec/core/formatters/syntax_highlighter_spec.rb || die
+
+ # Avoid a spec that depens on dev-ruby/rspec to lessen circular
+ # dependencies, bug 662328
+ sed -i -e '/loads mocks and expectations when the constants are referenced/askip "gentoo: bug 662328"' spec/rspec/core_spec.rb || die
}
each_ruby_prepare() {