summaryrefslogtreecommitdiff
path: root/dev-ruby/rspec-core/rspec-core-3.5.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
commit520a5b56dff7c24c9d42eafec142cb78b44f8e3e (patch)
treef562f705600dbd2292e97c0b4145787c2a8d1f97 /dev-ruby/rspec-core/rspec-core-3.5.4.ebuild
parent3811bc3072bf19e2be351d2c63f81532945c0f21 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'dev-ruby/rspec-core/rspec-core-3.5.4.ebuild')
-rw-r--r--dev-ruby/rspec-core/rspec-core-3.5.4.ebuild12
1 files changed, 3 insertions, 9 deletions
diff --git a/dev-ruby/rspec-core/rspec-core-3.5.4.ebuild b/dev-ruby/rspec-core/rspec-core-3.5.4.ebuild
index 0c937d52f425..8c95a2ed7487 100644
--- a/dev-ruby/rspec-core/rspec-core-3.5.4.ebuild
+++ b/dev-ruby/rspec-core/rspec-core-3.5.4.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+USE_RUBY="ruby23"
RUBY_FAKEGEM_TASK_TEST="none"
-RUBY_FAKEGEM_TASK_DOC="none"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
@@ -82,12 +82,6 @@ each_ruby_prepare() {
# esac
}
-all_ruby_compile() {
- if use doc ; then
- yardoc || die
- fi
-}
-
each_ruby_test() {
PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -Ilib bin/rspec spec || die "Tests failed."
}