summaryrefslogtreecommitdiff
path: root/dev-ruby/rr/rr-3.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-22 16:48:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-22 16:48:54 +0000
commitce163dcd0944d81d8406c9532b457535efca7a6d (patch)
treef7deea170544ce69e03c037101b7b5c1277966b4 /dev-ruby/rr/rr-3.1.0.ebuild
parent05ee8049e2326946a2cd1720f98384c864f0a804 (diff)
gentoo auto-resync : 22:01:2024 - 16:48:54
Diffstat (limited to 'dev-ruby/rr/rr-3.1.0.ebuild')
-rw-r--r--dev-ruby/rr/rr-3.1.0.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-ruby/rr/rr-3.1.0.ebuild b/dev-ruby/rr/rr-3.1.0.ebuild
index f00aea0655f5..3b3e44be3275 100644
--- a/dev-ruby/rr/rr-3.1.0.ebuild
+++ b/dev-ruby/rr/rr-3.1.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
@@ -13,19 +13,19 @@ RUBY_FAKEGEM_GEMSPEC=rr.gemspec
inherit ruby-fakegem
DESCRIPTION="A double framework featuring a selection of double techniques and a terse syntax"
-HOMEPAGE="https://rr.github.io/rr"
+HOMEPAGE="https://rr.github.io/rr/"
SRC_URI="https://github.com/rr/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE=""
+IUSE="test"
ruby_add_bdepend "test? (
dev-ruby/minitest
dev-ruby/diff-lcs
dev-ruby/test-unit-rr )"
-all_ruby_prepare() {
- rm Gemfile || die
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die
}