summaryrefslogtreecommitdiff
path: root/dev-ruby/rqrcode/rqrcode-2.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-30 15:10:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-30 15:10:23 +0100
commit27b0740bf48a0a181090a49d20f368ac8474e90b (patch)
treed715e035ea5c7dfe4a21b510e898913c33289cfa /dev-ruby/rqrcode/rqrcode-2.1.2.ebuild
parentad0412d0cafb8c04ce98024155cf99a4cc27db44 (diff)
gentoo auto-resync : 30:07:2022 - 15:10:23
Diffstat (limited to 'dev-ruby/rqrcode/rqrcode-2.1.2.ebuild')
-rw-r--r--dev-ruby/rqrcode/rqrcode-2.1.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/rqrcode/rqrcode-2.1.2.ebuild b/dev-ruby/rqrcode/rqrcode-2.1.2.ebuild
new file mode 100644
index 000000000000..1697439bcf43
--- /dev/null
+++ b/dev-ruby/rqrcode/rqrcode-2.1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="rqrcode.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for encoding QR Codes"
+HOMEPAGE="https://whomwah.github.io/rqrcode/"
+SRC_URI="https://github.com/whomwah/rqrcode/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/chunky_png:0
+ dev-ruby/rqrcode_core:1
+"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
+}