summaryrefslogtreecommitdiff
path: root/dev-ruby/rouge/rouge-2.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/rouge/rouge-2.2.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/rouge/rouge-2.2.0.ebuild')
-rw-r--r--dev-ruby/rouge/rouge-2.2.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/rouge/rouge-2.2.0.ebuild b/dev-ruby/rouge/rouge-2.2.0.ebuild
new file mode 100644
index 000000000000..b87df474b268
--- /dev/null
+++ b/dev-ruby/rouge/rouge-2.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Yet-another-markdown-parser using a strict syntax definition in pure Ruby"
+HOMEPAGE="https://github.com/jneen/rouge"
+#SRC_URI="https://github.com/jneen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/redcarpet )"
+ruby_add_rdepend "dev-ruby/redcarpet
+ !!dev-ruby/rouge:0"
+
+RESTRICT="test"
+# Depends on dev-ruby/wrong, which is not packaged yet.