summaryrefslogtreecommitdiff
path: root/dev-ruby/rotp/rotp-6.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-31 10:10:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-31 10:10:44 +0100
commit0fde6d7108b1ee9fc6ad186eff4978faa255db20 (patch)
tree54c45a4fb87434f176ae2cc91c764acdcc1122e7 /dev-ruby/rotp/rotp-6.3.0.ebuild
parent025c71a90f259ca9319b4caa92495e43acf489b0 (diff)
gentoo auto-resync : 31:08:2023 - 10:10:44
Diffstat (limited to 'dev-ruby/rotp/rotp-6.3.0.ebuild')
-rw-r--r--dev-ruby/rotp/rotp-6.3.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/rotp/rotp-6.3.0.ebuild b/dev-ruby/rotp/rotp-6.3.0.ebuild
new file mode 100644
index 000000000000..6391c986bf9c
--- /dev/null
+++ b/dev-ruby/rotp/rotp-6.3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="The Ruby One Time Password Library"
+HOMEPAGE="https://github.com/mdp/rotp"
+SRC_URI="https://github.com/mdp/rotp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/openssl"
+
+ruby_add_bdepend "
+ test? ( >=dev-ruby/timecop-0.8 )
+"
+
+all_ruby_prepare() {
+ # Remove simplecov
+ sed -i -e '/simplecov/,/^end/ s:^:#:' -e '2irequire "uri"; require "cgi"' spec/spec_helper.rb || die
+ # Don't require git
+ sed -i \
+ -e 's/git ls-files/find/' \
+ -e 's/{test,spec,features}/spec/' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+}