summaryrefslogtreecommitdiff
path: root/dev-ruby/robots/robots-0.10.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-ruby/robots/robots-0.10.1-r3.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-ruby/robots/robots-0.10.1-r3.ebuild')
-rw-r--r--dev-ruby/robots/robots-0.10.1-r3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/robots/robots-0.10.1-r3.ebuild b/dev-ruby/robots/robots-0.10.1-r3.ebuild
new file mode 100644
index 000000000000..d6175ebefe8b
--- /dev/null
+++ b/dev-ruby/robots/robots-0.10.1-r3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple Ruby library to parse robots.txt"
+HOMEPAGE="https://rubygems.org/gems/robots"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's:rake/rdoctask:rdoc/task:' Rakefile || die
+}