summaryrefslogtreecommitdiff
path: root/dev-ruby/roadie/roadie-3.2.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/roadie/roadie-3.2.1-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/roadie/roadie-3.2.1-r2.ebuild')
-rw-r--r--dev-ruby/roadie/roadie-3.2.1-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/roadie/roadie-3.2.1-r2.ebuild b/dev-ruby/roadie/roadie-3.2.1-r2.ebuild
new file mode 100644
index 000000000000..b7f0d2a9ca48
--- /dev/null
+++ b/dev-ruby/roadie/roadie-3.2.1-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby21 ruby22 ruby23"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Making HTML emails comfortable for the Rails rockstars"
+HOMEPAGE="https://github.com/Mange/roadie"
+SRC_URI="https://github.com/Mange/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/nokogiri-1.5.0
+ >=dev-ruby/css_parser-1.4.5 =dev-ruby/css_parser-1.4*"
+ruby_add_bdepend "test? ( dev-ruby/rspec-collection_matchers dev-ruby/webmock )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e 's/git ls-files/find . -type f -print/' \
+ -e '/test_files/d' \
+ -e '/css_parser/ s/~>/>=/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}