summaryrefslogtreecommitdiff
path: root/dev-ruby/roadie-rails/roadie-rails-1.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-ruby/roadie-rails/roadie-rails-1.2.1.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/roadie-rails/roadie-rails-1.2.1.ebuild')
-rw-r--r--dev-ruby/roadie-rails/roadie-rails-1.2.1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-ruby/roadie-rails/roadie-rails-1.2.1.ebuild b/dev-ruby/roadie-rails/roadie-rails-1.2.1.ebuild
deleted file mode 100644
index 5553775ef4bb..000000000000
--- a/dev-ruby/roadie-rails/roadie-rails-1.2.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_RECIPE_DOC="yard"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Hooks Roadie into your Rails application to help with email generation"
-HOMEPAGE="https://github.com/Mange/roadie-rails"
-SRC_URI="https://github.com/Mange/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-#RESTRICT="test"
-
-ruby_add_rdepend ">=dev-ruby/roadie-3.1
- >=dev-ruby/railties-3.0:* <dev-ruby/railties-5.1:*"
-ruby_add_bdepend "
- test? (
- dev-ruby/bundler
- dev-ruby/rspec-rails
- dev-ruby/rspec-collection_matchers )"
-
-all_ruby_prepare() {
- sed -i -e '/development/,$ d' Gemfile || die
- sed -i -e 's/git ls-files/find . -print/' ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-each_ruby_test() {
- ${RUBY} -S bundle exec rspec-3 spec || die
-}