summaryrefslogtreecommitdiff
path: root/dev-ruby/rkelly-remix/rkelly-remix-0.0.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/rkelly-remix/rkelly-remix-0.0.7.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/rkelly-remix/rkelly-remix-0.0.7.ebuild')
-rw-r--r--dev-ruby/rkelly-remix/rkelly-remix-0.0.7.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/rkelly-remix/rkelly-remix-0.0.7.ebuild b/dev-ruby/rkelly-remix/rkelly-remix-0.0.7.ebuild
new file mode 100644
index 000000000000..d28d09a4102a
--- /dev/null
+++ b/dev-ruby/rkelly-remix/rkelly-remix-0.0.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="RKelly Remix is a fork of the RKelly JavaScript parser"
+HOMEPAGE="https://github.com/nene/rkelly-remix"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~x86"
+SLOT="0"
+IUSE="doc"
+
+ruby_add_bdepend "doc? ( dev-ruby/hoe dev-ruby/rdoc )"
+
+each_ruby_test() {
+ ${RUBY} -S testrb-2 -Ilib:. test/test_*.rb test/*/test_*.rb || die
+}