summaryrefslogtreecommitdiff
path: root/dev-ruby/ritex/ritex-1.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/ritex/ritex-1.0.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/ritex/ritex-1.0.1.ebuild')
-rw-r--r--dev-ruby/ritex/ritex-1.0.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/ritex/ritex-1.0.1.ebuild b/dev-ruby/ritex/ritex-1.0.1.ebuild
new file mode 100644
index 000000000000..21afed602b3c
--- /dev/null
+++ b/dev-ruby/ritex/ritex-1.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README ReleaseNotes"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Converts expressions from WebTeX into MathML"
+HOMEPAGE="http://masanjin.net/ritex/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/racc"
+DEPEND+=" test? ( app-text/itex2mml )"
+
+all_ruby_prepare() {
+ # Fix tests
+ sed -i -e "s#\./itex2MML#/usr/bin/itex2MML#;142d" test/mathml.rb || die
+ sed -i -e "12d" test/answer-key.yaml || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. test/all.rb || die
+}