summaryrefslogtreecommitdiff
path: root/dev-ruby/rex-sslscan/rex-sslscan-0.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/rex-sslscan/rex-sslscan-0.1.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/rex-sslscan/rex-sslscan-0.1.3.ebuild')
-rw-r--r--dev-ruby/rex-sslscan/rex-sslscan-0.1.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/rex-sslscan/rex-sslscan-0.1.3.ebuild b/dev-ruby/rex-sslscan/rex-sslscan-0.1.3.ebuild
new file mode 100644
index 000000000000..5724f2b6e2f6
--- /dev/null
+++ b/dev-ruby/rex-sslscan/rex-sslscan-0.1.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23"
+#RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="ruby implmenetation of the SSLScan tool "
+HOMEPAGE="https://rubygems.org/gems/rex-sslscan"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+# doesn't seem to actually run any tests
+RESTRICT=test
+
+PDEPEND="dev-libs/openssl"
+ruby_add_rdepend "dev-ruby/rex-socket dev-ruby/rex-text"