summaryrefslogtreecommitdiff
path: root/dev-ruby/rex-random_identifier
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /dev-ruby/rex-random_identifier
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'dev-ruby/rex-random_identifier')
-rw-r--r--dev-ruby/rex-random_identifier/Manifest2
-rw-r--r--dev-ruby/rex-random_identifier/rex-random_identifier-0.1.4.ebuild24
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/rex-random_identifier/Manifest b/dev-ruby/rex-random_identifier/Manifest
index b1218594ed30..8ed7ba0d418d 100644
--- a/dev-ruby/rex-random_identifier/Manifest
+++ b/dev-ruby/rex-random_identifier/Manifest
@@ -1,3 +1,5 @@
DIST rex-random_identifier-0.1.0.gem 15872 BLAKE2B f8afe34e9a33e08e04c7ebe5df47ce50a2cfea42359e517ab44ab3a8f96227f4ccbc532e0c0b284bcba2291ad9ed6f85064435522b58c17a98d78cbd6d75cdc4 SHA512 79439b80ad06c6c5c7854933eaa4129ff0b176144bebf68fdfe7250ab3242904bcae4a439d610f4710b6d48ee5405b0d5f79539c861511072fb628ee68afd21f
+DIST rex-random_identifier-0.1.4.gem 16896 BLAKE2B 37c1011b91dd16a82c0ee8ff1c96b0263c4842503826bae327d3a6d3b61dac77620cbd28cba350c0cf56bc5fc480bc37663a78674d0c7c8d8d6bb95e046e9559 SHA512 8e302a511a0540f826ddfa6e51c5b29da0c42ef6bd3dc433d6624688efba245c1df3903dbf37aacaecdd39b53f721e3d6b4fa8247f8cd31e7679ff96293094f7
EBUILD rex-random_identifier-0.1.0-r1.ebuild 562 BLAKE2B 7e6370cca3bddcfc2e8d9bafb95dba9931b5ea078e7f0e51fa9d9d11920f7fb6ef976038a6c2c2d9055770028b8516877d88e4a9103e5c3871e889dc663ccd07 SHA512 c877e9dd4632c096ffb19395e632c09b55db238e9cd53c31e3cbafd0eea12117efb39996606ea6323f20597c76721c80641011a17302bd88bc53ad817d67631f
+EBUILD rex-random_identifier-0.1.4.ebuild 571 BLAKE2B 14fc1548b1c0284be4d5d162dc841bb6953c94e41d1f3c6fe83b43c5ed2dfd82784121cc60fc7b46ff1dd59ffc2317490edb84d4c74365d9c83459ffe2458462 SHA512 d9dfc852413874a5b54a5dfea67355283be4360a74a12ab7d4a443f6fdd96b1840bd8e420d06b2655d8f4a8ab3816727bda348db5d6680a09d398994494d4157
MISC metadata.xml 415 BLAKE2B 4ad85703d580032450110f21f844d19374c9104ad88b215d70688e8bc6b175c5d706a1afd793196440a1ae39dedf9342c19d34a0c295604d3f15ef112261a9e3 SHA512 9da0baa565c2f611e562aa78eeae7755603721a3d934d63552b8858efda0d379b2a479735d256b318a440305363776b8f4f352ff10201be2dd0397bd38cf0abe
diff --git a/dev-ruby/rex-random_identifier/rex-random_identifier-0.1.4.ebuild b/dev-ruby/rex-random_identifier/rex-random_identifier-0.1.4.ebuild
new file mode 100644
index 000000000000..2f06cc7c2317
--- /dev/null
+++ b/dev-ruby/rex-random_identifier/rex-random_identifier-0.1.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+# Upstream has specs but they are not released and upstream is not tagged
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby Exploitation(Rex) library for generating Random identifier strings"
+HOMEPAGE="https://rubygems.org/gems/rex-random_identifier"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_bdepend "dev-ruby/rex-text"