summaryrefslogtreecommitdiff
path: root/dev-ruby/rex-powershell
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/rex-powershell
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/rex-powershell')
-rw-r--r--dev-ruby/rex-powershell/Manifest5
-rw-r--r--dev-ruby/rex-powershell/metadata.xml12
-rw-r--r--dev-ruby/rex-powershell/rex-powershell-0.1.77.ebuild24
-rw-r--r--dev-ruby/rex-powershell/rex-powershell-0.1.78.ebuild24
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-ruby/rex-powershell/Manifest b/dev-ruby/rex-powershell/Manifest
new file mode 100644
index 000000000000..e5c777bbc3a9
--- /dev/null
+++ b/dev-ruby/rex-powershell/Manifest
@@ -0,0 +1,5 @@
+DIST rex-powershell-0.1.77.gem 28160 BLAKE2B d1fb9f6e9f66e6b55b09bdda329037ea7da135b9eaec9f1437ca374f3be5da1b5ee63f7c92d56447c88964a4c1a4bef68b2d6b64a4e507b7c2a7010f1ff09d40 SHA512 99e3a8394c580b07580f8c230f049b15fd80b02db4b940208a1086e1c3d679ab1b757fee56356d6b25a6876ccb21c50d1037b7bbadc486a7c38b10b9b81a09d3
+DIST rex-powershell-0.1.78.gem 28160 BLAKE2B 922a4a6f8605335c664fbdad7e6214bdd48dff5d648eb324f92a5f48dd62d2a0b98283f4cddd4ccb8190b78b1c1a637190a836d0d0b486c80b18e383fa49820a SHA512 db3e1cf0e10d6454fb5b5b76e346fa7f299f14e8d2399ee7f863708444bd6404984a16bc2fccedcc1f06a1eac7add63fc75c5f1d2b8c9fb5c421817e385000cc
+EBUILD rex-powershell-0.1.77.ebuild 537 BLAKE2B 3db094c5379606ab5db1b8e006f45ff14832611f640478af83e8620eecb6336f40c5de9547b1585f6d2a26b1a496452cd3549d0dd7be778bf466f28b01301047 SHA512 30f79caa12c09d40f493cba08cc85695a6d14d1bfad439cfeb7a81d7fab44f8145db7ef1a104b05880f14cdc3cd2c16f477a3e0736e7642864311fe07ef4f7eb
+EBUILD rex-powershell-0.1.78.ebuild 537 BLAKE2B 3db094c5379606ab5db1b8e006f45ff14832611f640478af83e8620eecb6336f40c5de9547b1585f6d2a26b1a496452cd3549d0dd7be778bf466f28b01301047 SHA512 30f79caa12c09d40f493cba08cc85695a6d14d1bfad439cfeb7a81d7fab44f8145db7ef1a104b05880f14cdc3cd2c16f477a3e0736e7642864311fe07ef4f7eb
+MISC metadata.xml 401 BLAKE2B 9ced95a371f0f76b272ae92fdb6955e87481fe0e5054d87ead013f86a91e83573aac67611acb9da9c765b8e6970a71cc99714ce9e6b0a52d66f7da5f2a365134 SHA512 1960bdc2bd8ecd7b03969c7dc24374ea46e45a7b7218c7d5f0677aa6906e191908416919302f5d9082c35021d7be414040852c33e457eb6d8ad5030e95b4bb52
diff --git a/dev-ruby/rex-powershell/metadata.xml b/dev-ruby/rex-powershell/metadata.xml
new file mode 100644
index 000000000000..48105fc5a97b
--- /dev/null
+++ b/dev-ruby/rex-powershell/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rapid7/rex-powershell</remote-id>
+ <remote-id type="rubygems">rex-powershell</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rex-powershell/rex-powershell-0.1.77.ebuild b/dev-ruby/rex-powershell/rex-powershell-0.1.77.ebuild
new file mode 100644
index 000000000000..d44f1014de16
--- /dev/null
+++ b/dev-ruby/rex-powershell/rex-powershell-0.1.77.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby Exploitation(Rex) library for generating/manipulating Powershell scripts"
+HOMEPAGE="https://rubygems.org/gems/rex-powershell"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_bdepend "dev-ruby/rex-random_identifier
+ dev-ruby/rex-text"
diff --git a/dev-ruby/rex-powershell/rex-powershell-0.1.78.ebuild b/dev-ruby/rex-powershell/rex-powershell-0.1.78.ebuild
new file mode 100644
index 000000000000..d44f1014de16
--- /dev/null
+++ b/dev-ruby/rex-powershell/rex-powershell-0.1.78.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby Exploitation(Rex) library for generating/manipulating Powershell scripts"
+HOMEPAGE="https://rubygems.org/gems/rex-powershell"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_bdepend "dev-ruby/rex-random_identifier
+ dev-ruby/rex-text"