summaryrefslogtreecommitdiff
path: root/dev-ruby/reline/reline-0.5.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-04 00:00:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-04 00:00:19 +0100
commit7f3fecbb5b871825fe9632f46659869cab6a3769 (patch)
treedd2be4fe7ee3475ca4ad093698f0f8fd1e0965dc /dev-ruby/reline/reline-0.5.5.ebuild
parenta98588cfddf3d6e88a5f17d7f399b695163c7a85 (diff)
gentoo auto-resync : 04:05:2024 - 00:00:19
Diffstat (limited to 'dev-ruby/reline/reline-0.5.5.ebuild')
-rw-r--r--dev-ruby/reline/reline-0.5.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/reline/reline-0.5.5.ebuild b/dev-ruby/reline/reline-0.5.5.ebuild
new file mode 100644
index 000000000000..a779c43093ce
--- /dev/null
+++ b/dev-ruby/reline/reline-0.5.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md doc/reline/face.md"
+RUBY_FAKEGEM_GEMSPEC="reline.gemspec"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Alternative readline implementation in pure Ruby"
+HOMEPAGE="https://github.com/ruby/reline"
+SRC_URI="https://github.com/ruby/reline/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+ruby_add_rdepend ">=dev-ruby/io-console-0.5.0:0"
+
+all_ruby_prepare() {
+ sed -e "s:_relative ':'./:" \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test/reline -rhelper -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}