summaryrefslogtreecommitdiff
path: root/dev-ruby/rdiscount
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-26 09:55:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-26 09:55:31 +0100
commit9a8514e070a40648dbc8e28ad6457d925542b79a (patch)
tree5cc8ed0b0c8964ad196b7b3e502def202a997b32 /dev-ruby/rdiscount
parent2ecd7994be1409f2a65bfca700904d2a78fd7bbe (diff)
gentoo auto-resync : 26:10:2022 - 09:55:31
Diffstat (limited to 'dev-ruby/rdiscount')
-rw-r--r--dev-ruby/rdiscount/Manifest2
-rw-r--r--dev-ruby/rdiscount/rdiscount-2.2.7.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/rdiscount/Manifest b/dev-ruby/rdiscount/Manifest
index 1a73ceff5f4a..958501ce5435 100644
--- a/dev-ruby/rdiscount/Manifest
+++ b/dev-ruby/rdiscount/Manifest
@@ -1,4 +1,6 @@
DIST rdiscount-2.2.0.2.gem 68096 BLAKE2B 91f67643103a46f3fc95f80191a85ce4c89bba6a83f7ed5542cc9ec1671628c6ac0543b206d87e2ffc469dc83139e5669ee7eb6713eba4116db19c071a15f402 SHA512 97a0fabb77238173f101298e4b4b6d4728b9e15cb7d3f14e7d1d978c44ab92dd89c2e02d0c15c0fa70a836eb54abca06b0027e26e5d87540bfe145c8527be3f7
+DIST rdiscount-2.2.7.gem 73728 BLAKE2B 0d63372c3e2f4fa1efeef12ec4f8a2b12b9fccd7506ac6609d7e8fea958e04cfa1cc96a484ffba17d643838705d52c1557604ca015fded282ec860a7fc2481a5 SHA512 4f60dc0dbfb6b8f95f80d577c872c2a747d7d15e9fc1f1bd3640f1207a5d262068754dcb6d7b53348fd69de20b85534a390aace35d1eff31112bfbe0f77569d1
EBUILD rdiscount-2.2.0.2-r1.ebuild 1114 BLAKE2B df26b85c4cf30b6a4fc3693a091fce629a2afc73e8c3f5db4c8de85223c609f9a7ffcdd1922cd1fcaef36b252029fde67792e1e6cb45e612c431b89521498d31 SHA512 cf29664dfea2fcdc91250d4b4bb493f325e07068b2fc84c87c1ecdb53e7ca4b4af91d5a52bc517453b0a24bb5ede24ebf074f3a0478b3b0984502bb4cd7296ec
EBUILD rdiscount-2.2.0.2-r2.ebuild 1118 BLAKE2B 723944f06b87e89ed2317d6145db5db8c34b080d5d9d554aa6dd11a1db9d23a78764fa694b20fc45feb73d41070d4637d8a5dffa06444b5da7cd5e41e9f0da55 SHA512 983556dd6ef7a5b90f55078d1ba2408ed19bb7cc277a79332d831666d560a7d27f016e48bc927e24f25f114d05e08ee4c3c1546d97f86cff0e4640a3df728509
+EBUILD rdiscount-2.2.7.ebuild 1111 BLAKE2B 119c3bb383ad58fa14d820d786ad133db18b501fab33b328b770bf7b26358e13ff78138b5b1ec34fd810e831f4e37031f8051cbee372a02a33389a646c3953ac SHA512 bbb072eeb4ef14c0311d190f112e94acca5fb4ce34661dd022f0de335dfb97a3909499d5149c344e70ab3bfca6409e2be5d0a941e78e0da90b011ca520f37c60
MISC metadata.xml 345 BLAKE2B 83db3067d2cf0eeb028bd4793935cb94fe99eb2bff345e02fce72c35613c5c14dc266a8b366a3b518f007b6310ddc3130b3ac1f9a3e52c4940d83bfd6eac1889 SHA512 b771eeb7ff43472f242114cec8f8b1e8dd09715e0b35c1095bfd7d61b1149ec32fc05ea7153704369a270bd267d42ae0e532fab16fc7e6ca11a4454800d72900
diff --git a/dev-ruby/rdiscount/rdiscount-2.2.7.ebuild b/dev-ruby/rdiscount/rdiscount-2.2.7.ebuild
new file mode 100644
index 000000000000..1c7295f8c7ed
--- /dev/null
+++ b/dev-ruby/rdiscount/rdiscount-2.2.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_TASK_TEST="test:unit"
+
+RUBY_FAKEGEM_TASK_DOC="doc man"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implementation of John Gruber's Markdown"
+HOMEPAGE="https://github.com/rtomayko/rdiscount"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ # Hanna is broken for us and therefore we don't have it in portage.
+ sed -i -e 's/hanna/rdoc/' Rakefile || die
+
+ # Remove rule that will force a rebuild when running tests.
+ sed -i -e "/task 'test:unit' => \[:build\]/d" Rakefile || die
+
+ # Provide RUBY variable no longer provided by rake.
+ sed -i -e "1 iRUBY=${RUBY}" Rakefile || die
+
+ # Remove obsolete -rubygems argument, bug 775377
+ sed -i -e '/-rubygems/ s:^:#:' Rakefile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/rdiscount.1
+}