summaryrefslogtreecommitdiff
path: root/dev-ruby/rb-inotify/rb-inotify-0.9.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/rb-inotify/rb-inotify-0.9.9.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/rb-inotify/rb-inotify-0.9.9.ebuild')
-rw-r--r--dev-ruby/rb-inotify/rb-inotify-0.9.9.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/rb-inotify/rb-inotify-0.9.9.ebuild b/dev-ruby/rb-inotify/rb-inotify-0.9.9.ebuild
new file mode 100644
index 000000000000..407ac93665ea
--- /dev/null
+++ b/dev-ruby/rb-inotify/rb-inotify-0.9.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A thorough inotify wrapper for Ruby using FFI"
+HOMEPAGE="https://github.com/nex3/rb-inotify"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "virtual/ruby-ffi"
+
+all_ruby_prepare() {
+ # Avoid unneeded dependency on jeweler.
+ sed -i -e '/:build/ s:^:#:' -e '/module Jeweler/,/^end/ s:^:#:' -e '/class Jeweler/,/^end/ s:^:#:' Rakefile || die
+
+ # Remove mandatory markup processor from yard options, bug 436112.
+ sed -i -e '/maruku/d' .yardopts || die
+
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
+}