summaryrefslogtreecommitdiff
path: root/dev-ruby/rb-gsl/rb-gsl-2.1.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /dev-ruby/rb-gsl/rb-gsl-2.1.0.1.ebuild
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'dev-ruby/rb-gsl/rb-gsl-2.1.0.1.ebuild')
-rw-r--r--dev-ruby/rb-gsl/rb-gsl-2.1.0.1.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-ruby/rb-gsl/rb-gsl-2.1.0.1.ebuild b/dev-ruby/rb-gsl/rb-gsl-2.1.0.1.ebuild
deleted file mode 100644
index 9b2217b37572..000000000000
--- a/dev-ruby/rb-gsl/rb-gsl-2.1.0.1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby22 ruby23"
-
-RUBY_FAKEGEM_NAME="gsl"
-inherit ruby-fakegem multilib
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="ChangeLog README.md"
-
-DESCRIPTION="Ruby interface to GNU Scientific Library"
-HOMEPAGE="https://github.com/SciRuby/rb-gsl"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc"
-
-DEPEND+=" >=sci-libs/gsl-2.3[deprecated]"
-RDEPEND+=" >=sci-libs/gsl-2.3[deprecated]"
-
-RUBY_S="${PN}-${P}"
-
-RUBY_PATCHES=( "${FILESDIR}"/${P}-narray-superclass.patch )
-
-ruby_add_bdepend "dev-ruby/narray"
-ruby_add_rdepend "dev-ruby/narray"
-
-all_ruby_prepare() {
- sed -i -e '/LOCAL_LIBS/ s: -l: -L#{path.gsub("ext", "lib")} -l:' ext/gsl_native/extconf.rb || die
- # nmatrix only tests
- rm -r test/gsl/nmatrix_tests || die
-}
-
-each_ruby_configure() {
- NARRAY=1 ${RUBY} -Cext/gsl_native extconf.rb || die
- sed -i -e 's:-Wl,--no-undefined::' ext/gsl_native/Makefile || die
-}
-
-each_ruby_compile() {
- NARRAY=1 emake -Cext/gsl_native V=1
- cp ext/gsl_native/*$(get_modname) lib/ || die
-}
-
-each_ruby_test() {
- NARRAY=1 ${RUBY} -Ilib:test:. -e 'Dir["test/**/*_test.rb"].each{|f| require f}' || die
-}