summaryrefslogtreecommitdiff
path: root/dev-ruby/rantly/rantly-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-ruby/rantly/rantly-2.0.0.ebuild
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-ruby/rantly/rantly-2.0.0.ebuild')
-rw-r--r--dev-ruby/rantly/rantly-2.0.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ruby/rantly/rantly-2.0.0.ebuild b/dev-ruby/rantly/rantly-2.0.0.ebuild
new file mode 100644
index 000000000000..4c2e275a6cc1
--- /dev/null
+++ b/dev-ruby/rantly/rantly-2.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby Imperative Random Data Generator and Quickcheck"
+HOMEPAGE="https://github.com/rantly-rb/rantly"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/**/*_test.rb"].each{|f| require f}' || die
+}