summaryrefslogtreecommitdiff
path: root/dev-ruby/rantly/rantly-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-ruby/rantly/rantly-2.0.0.ebuild
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-ruby/rantly/rantly-2.0.0.ebuild')
-rw-r--r--dev-ruby/rantly/rantly-2.0.0.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-ruby/rantly/rantly-2.0.0.ebuild b/dev-ruby/rantly/rantly-2.0.0.ebuild
index 4c2e275a6cc1..933b123125c6 100644
--- a/dev-ruby/rantly/rantly-2.0.0.ebuild
+++ b/dev-ruby/rantly/rantly-2.0.0.ebuild
@@ -16,6 +16,10 @@ SLOT="$(ver_cut 1)"
KEYWORDS="~amd64"
IUSE=""
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/^end/ s:^:#:' test/test_helper.rb || die
+}
+
each_ruby_test() {
${RUBY} -Ilib:test:. -e 'Dir["test/**/*_test.rb"].each{|f| require f}' || die
}