summaryrefslogtreecommitdiff
path: root/dev-ruby/rack/rack-2.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-ruby/rack/rack-2.0.3.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/rack/rack-2.0.3.ebuild')
-rw-r--r--dev-ruby/rack/rack-2.0.3.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-ruby/rack/rack-2.0.3.ebuild b/dev-ruby/rack/rack-2.0.3.ebuild
deleted file mode 100644
index c701430d525f..000000000000
--- a/dev-ruby/rack/rack-2.0.3.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby21 ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="HISTORY.md README.rdoc SPEC"
-
-inherit ruby-fakegem eutils versionator
-
-DESCRIPTION="A modular Ruby webserver interface"
-HOMEPAGE="https://rack.github.com/"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RUBY_PATCHES=( ${PN}-1.2.1-gentoo.patch )
-
-ruby_add_rdepend "virtual/ruby-ssl"
-
-ruby_add_bdepend "test? ( dev-ruby/minitest:5 dev-ruby/concurrent-ruby )"
-
-# The gem has automagic dependencies over mongrel, ruby-openid,
-# memcache-client, thin, mongrel and camping; not sure if we should
-# make them dependencies at all.
-
-# Block against versions in older slots that also try to install a binary.
-RDEPEND="${RDEPEND} !<dev-ruby/rack-1.4.5-r1:1.4 !<dev-ruby/rack-1.5.2-r4:1.5 !<dev-ruby/rack-1.6.4-r2:1.6"
-
-all_ruby_prepare() {
- # The build system tries to generate the ChangeLog from git. Create
- # an empty file to avoid a needless dependency on git.
- touch ChangeLog || die
-
- # Avoid development dependency
- sed -i -e '/minitest-sprint/ s:^:#:' rack.gemspec || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:test:. -e "require 'test/gemloader.rb'; Dir['test/spec_*.rb'].each{|f| require f}" || die
-}