summaryrefslogtreecommitdiff
path: root/dev-ruby/rack-protection/rack-protection-3.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-08 12:15:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-08 12:15:59 +0000
commit6a57f9ee53dc794f3d47ea68f78d6ef76d00af47 (patch)
treedc9e574f3209abd88e91e2ee0d6093f4fe78e2d3 /dev-ruby/rack-protection/rack-protection-3.0.5.ebuild
parent268f9f01921ccb921b794d43092c5f29c1e96c56 (diff)
gentoo auto-resync : 08:01:2023 - 12:15:59
Diffstat (limited to 'dev-ruby/rack-protection/rack-protection-3.0.5.ebuild')
-rw-r--r--dev-ruby/rack-protection/rack-protection-3.0.5.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/rack-protection/rack-protection-3.0.5.ebuild b/dev-ruby/rack-protection/rack-protection-3.0.5.ebuild
new file mode 100644
index 000000000000..c1fe98e42fca
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-3.0.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+# There are no specs in the gem and the source cannot be downloaded separately.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem protects against typical web attacks"
+HOMEPAGE="https://github.com/rkh/rack-protection"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rack:*"
+
+# ruby_add_bdepend "test? ( dev-ruby/rack-test )"